Returns are an inevitable part of any retail business, and having a clear and straightforward process for conducting them is essential.
In this guide, we will provide you with step-by-step instructions on how to conduct a return on a Pin Debit transaction, ensuring that you can process debit card returns with ease and efficiency.
Conduct a return on a Pin Debit transaction
Step 1: Start the standard return process in KlickTrack
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Locate the transaction and click on it to open the "Sale" modal
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On the transaction “Sale” modal, press the “Return” button
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Select the items to be returned on the “Return Sale Items” modal
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Press the “Return” button
Step 2: Terminal Selection
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If you are a dispensary with multiple pin debit terminals set up, you must select the same terminal used to complete the sales transaction.
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If you only have one terminal set up, the system will use it by default.
You must select the same terminal that was used for the sales transaction or Spin will be unable to locate the sale and the void request will be aborted.
If you are unable to utilize the same terminal, then please complete the return from your Spin merchant portal.
Step 3: Return information is sent to the terminal
Once a terminal is selected, the register will connect to the terminal and send the return information.
Step 4: Customer enters their debit card information
Switch to the terminal and have the customer tap, swipe or insert the card they used for the initial sales transaction.
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You can also enter the card information manually by pressing the “Enter card” button on the terminal.
Step 5: Processing the return
The terminal will send the return request to the payment processor.
Step 6: Return confirmation
Once the confirmation response is received:
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The terminal will show a confirmation screen.
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The KlickTrack user will be shown the “Items Returned” sale modal
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The return receipt will be printed.
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This receipt will contain all of the necessary references you need to marry up the information in your Spin portal with your KlickTrack reports, including the Spin transaction ID.
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Troubleshooting a Pin Debit Return
In this section, we’ll go over common errors that could occur during a return and provide you with information on how to resolve these issues quickly.
The information below covers common issues related to returns, but other errors can occur. If you can't find your issue below, please check out our "Troubleshooting Pin Debit" article, which covers a broader array of potential errors.
Error Message | Potential Cause & Error Resolution |
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Unable to find transaction |
Potential Cause: This error generally occurs when the terminal selected for the return action is different from the one used for the sale transaction.
How to Resolve:
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Card mismatch |
Potential Cause: This error can occur when the customer taps / swipes / inserts a different card for the return than the one used for the sales transaction.
How to Resolve: Have the customer insert / swipe / tap the same card used for the sales transaction. |
Invalid Reference ID
OR
Request cannot be completed |
Potential Cause:
How to Resolve: If you receive this error, you will need to complete the return in the Spin merchant portal. |
Payment Terminal is currently busy
OR
Terminal in use |
Potential Cause: The terminal is unable to receive the transaction information because it is currently busy for whatever reason, including:
How to Resolve:
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Payment Terminal Not Found
OR
Register Not Found |
Potential Cause: The terminal is not active and/or cannot be found. This could be due to the following:
How to Resolve:
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Connection time out
OR
This transaction has timed out |
Potential Cause: The request was sent to the terminal, and, for whatever reason, the terminal did not respond in time. The payment terminal sends a default time-out response after 120 seconds of inactivity.
Potential causes of the time out:
How to Resolve:
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An unknown failure has occurred |
Potential Cause: Unknown failures can be caused by many things, including a system time-out, a dropped internet connection, a momentary hardware error, etc.
How to Resolve: Try completing the return on the same terminal again. If you receive this error a second time, we recommend checking your internet to ensure it’s not experiencing an outage. |